summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ee251ed1cce..ece00cd772c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,24 @@
pkgname=idevicerestore-git
epoch=1
-pkgver=r705.21a242e
+pkgver=1.0.0.r134.g163a164
pkgrel=1
pkgdesc="Restore/upgrade firmware of iOS devices"
arch=('i686' 'x86_64')
url="http://www.libimobiledevice.org"
license=('LGPL3')
-depends=('libirecovery-git' 'libimobiledevice' 'libzip' 'openssl' 'curl')
+depends=('libzip' 'openssl' 'curl' 'libimobiledevice-glue-git' 'libplist-git' 'libimobiledevice-git' 'libirecovery-git')
makedepends=('git')
source=("git+https://github.com/libimobiledevice/idevicerestore"
- "0001-configure.ac-check-for-pthreads.patch")
+ '0001-configure.ac-check-for-pthreads.patch'
+ '0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch')
sha256sums=('SKIP'
- 'd7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15')
+ 'd7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15'
+ 'b1348ccc86d0ccbbc5bf6fa4e2027b0303a52673431ace50cc1e0ef8a6171305')
pkgver() {
cd idevicerestore
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/[^-]*-g/r&/;s/-/./g'
}
prepare() {
@@ -31,10 +33,16 @@ prepare() {
build() {
cd idevicerestore
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ #sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # not needed anymore (libtool honors $LDFLAGS now)
make
}
+check() {
+ cd idevicerestore
+ make check
+}
+
package() {
cd idevicerestore
make DESTDIR="$pkgdir" install