summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 25 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21bf20d44731..a85afd7a136c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,29 @@
# Contributor: Tobias Luther <tobias [at] tonstrom [dot] de>
pkgname=idjc-git
-pkgver=796.179dfef
+pkgver=882.7e4ff89
pkgrel=1
-pkgdesc="A graphical shoutcast and icecast client."
+pkgdesc="Powerful client for individuals interested in streaming live radio shows"
arch=(i686 x86_64)
url="http://idjc.sourceforge.net/"
-depends=('python2' 'jack' 'pygtk' 'lame' 'mutagen' 'flac' 'faad2' 'libsamplerate' 'vorbis-tools' 'libsndfile' 'ffmpeg-compat' 'libmad' 'speex' 'dbus-python' 'imagemagick' 'twolame' 'libshout-idjc-git' 'mpg123' 'twolame')
+depends=('dbus-python'
+ 'desktop-file-utils'
+ 'ffmpeg'
+ 'flac'
+ 'glib2'
+ 'jack'
+ 'lame'
+ 'libmad'
+ 'libsamplerate'
+ 'libshout-idjc-git'
+ 'libsndfile'
+ 'mutagen'
+ 'pygtk'
+ 'python2'
+ 'speex'
+ 'twolame'
+ 'vorbis-tools'
+)
makedepends=('git')
optdepends=('mysql-python: Ampache and Prokyon 3 support')
conflicts=('idjc')
@@ -19,8 +36,11 @@ build()
{
cd idjc
./bootstrap
- PKG_CONFIG_PATH+="/usr/lib/ffmpeg-compat/pkgconfig"
- ./configure --prefix=/usr CFLAGS="-O2" PYTHON="/usr/bin/python2"
+ export PYTHON=/usr/bin/python2
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --disable-static
make
}
@@ -28,8 +48,6 @@ package()
{
cd idjc
make DESTDIR=$pkgdir install
- cd $pkgdir/usr/bin
- sed -i -e 's/python22.7/python2/' idjc
}
pkgver() {