summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed2eac539d95..7e4cd289c400 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=ikos
pkgver=2.0
-pkgrel=1
+pkgrel=2
pkgdesc='A static analyzer for C and C++ developed by NASA'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
-url='https://ti.arc.nasa.gov/opensource/ikos/'
+url='https://github.com/nasa-sw-vnv/ikos'
license=('custom:NOSA 1.3')
depends=('gmp'
'boost-libs'
@@ -18,10 +18,8 @@ depends=('gmp'
'apron-ppl-svn')
makedepends=('cmake'
'boost')
-source=("https://ti.arc.nasa.gov/m/opensource/downloads/ikos-$pkgver.tar.gz"
- "https://ti.arc.nasa.gov/m/opensource/downloads/ikos/IKOS_NASA_Open_Source_Agreement.pdf")
-sha512sums=('f3abb77e9d3d57b26cb0df7d26b1cb824441c178205edc7b92b3b137d6b2b12b9f7336d53f5135a8a0f114042c193419945553fac0f91b59235e8ed5849fb3d5'
- '3caeffbe06254b3a181eee1f172bde48d7c8007e989b07928b0ce4e737759d5e2649d25419722c3b7a78ca8ddf408ce150a143490489641527cbcac479c241b7')
+source=("https://github.com/nasa-sw-vnv/ikos/releases/download/v$pkgver/ikos-$pkgver.tar.gz")
+sha256sums=('03a93794651e51e639c47b8ef821f923f7951a11669a7ad3230a68f5f27e1c5f')
prepare() {
cd "$srcdir/ikos-$pkgver"
@@ -41,7 +39,7 @@ build() {
package() {
cd "$srcdir/ikos-$pkgver/build"
make DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir/IKOS_NASA_Open_Source_Agreement.pdf" "${pkgdir}/usr/share/licenses/ikos/LICENSE"
+ install -Dm644 "$srcdir/ikos-$pkgver/LICENSE.pdf" "$pkgdir/usr/share/licenses/ikos/LICENSE"
}
check() {