summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 23 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45a0aea1983d..b7de32cd1779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Maintainer: Isabella Basso do Amaral <isabbasso at riseup dot net>
# Contributor: Eric BĂ©langer <eric@archlinux.org>
pkgbase=imagemagick-fftw
pkgname=(imagemagick-fftw)
-pkgver=7.0.8.45
+pkgver=7.1.1.10
pkgrel=1
-pkgdesc="An image viewing/manipulation program"
-url="https://www.imagemagick.org/"
+pkgdesc='An image viewing/manipulation program'
+url='https://www.imagemagick.org/'
arch=(x86_64)
license=(custom)
-makedepends=(ghostscript openexr libwmf librsvg libxml2 openjpeg2 libraw opencl-headers libwebp
- chrpath ocl-icd glu ghostpcl ghostxps libheif jbigkit lcms2 libxext liblqr libraqm libpng 'fftw')
+makedepends=(ghostscript openexr libwmf librsvg libxml2 openjpeg2 libraw opencl-headers libwebp libzip
+ chrpath ocl-icd glu ghostpcl ghostxps libheif jbigkit lcms2 libxext liblqr libraqm libpng djvulibre 'fftw')
checkdepends=(gsfonts ttf-dejavu)
_relname=ImageMagick-${pkgver%%.*}
-_tarname=ImageMagick-${pkgver%.*}-${pkgver##*.}
-source=(https://www.imagemagick.org/download/releases/$_tarname.tar.xz{,.asc}
- arch-fonts.diff IM7-GS-policy.patch)
-sha256sums=('d892b41a08b24baa058bc59cee2dd329584525446e03a414bc250b93a2f2fc79'
- 'SKIP'
- 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73'
- 'f20c09860da65a4259ec9627ceeca7d993949b7460fa199c5ffd874633814cf6')
+_tarname=${pkgver%.*}-${pkgver##*.}
+_dirname=ImageMagick-$_tarname
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/ImageMagick/ImageMagick/archive/refs/tags/$_tarname.tar.gz
+ arch-fonts.diff)
+sha256sums=('5008d827a78b56d436f532e6b6f7b6d4a69aa59342ce3dae00383f4686718c89'
+ 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73')
validpgpkeys=(D8272EF51DA223E4D05B466989AB63D48277377A) # Lexie Parsimoniae
shopt -s extglob
@@ -27,20 +26,18 @@ shopt -s extglob
prepare() {
mkdir -p docpkg/usr/share
- cd $_tarname
+ cd $_dirname
# Fix up typemaps to match our packages, where possible
patch -p1 -i ../arch-fonts.diff
-
- # Work around ghostscript security issues https://bugs.archlinux.org/task/59778
- patch -p1 -i ../IM7-GS-policy.patch
}
build() {
- cd $_tarname
+ cd $_dirname
./configure \
--prefix=/usr \
--sysconfdir=/etc \
+ --enable-shared \
--with-dejavu-font-dir=/usr/share/fonts/TTF \
--with-gs-font-dir=/usr/share/fonts/gsfonts \
PSDelegate=/usr/bin/gs \
@@ -48,7 +45,8 @@ build() {
PCLDelegate=/usr/bin/gpcl6 \
--enable-hdri \
--enable-opencl \
- --with-gslib \
+ --without-gslib \
+ --with-djvu \
--with-lqr \
--with-modules \
--with-openexr \
@@ -60,7 +58,6 @@ build() {
--with-wmf \
--with-xml \
--without-autotrace \
- --without-djvu \
--without-dps \
--with-fftw \
--without-fpx \
@@ -71,9 +68,8 @@ build() {
}
check() (
- cd $_tarname
+ cd $_dirname
ulimit -n 4096
- sed -e '/validate-formats/d' -i Makefile # these fail due to the security patch
make check
)
@@ -89,6 +85,7 @@ package_imagemagick-fftw() {
'ocl-icd: OpenCL support'
'openexr: OpenEXR support'
'openjpeg2: JPEG2000 support'
+ 'djvulibre: DJVU support'
'pango: Text rendering'
'imagemagick-doc: manual and API docs')
options=(!emptydirs libtool)
@@ -97,7 +94,7 @@ package_imagemagick-fftw() {
provides=(libmagick libmagick-fftw imagemagick=$pkgver)
replaces=(libmagick-fftw)
- cd $_tarname
+ cd $_dirname
make DESTDIR="$pkgdir" install
find "$pkgdir/usr/lib/perl5" -name '*.so' -exec chrpath -d {} +
@@ -108,5 +105,8 @@ package_imagemagick-fftw() {
# Split docs
mv "$pkgdir/usr/share/doc" "$srcdir/docpkg/usr/share/"
+
+# Harden security policy https://bugs.archlinux.org/task/62785
+ sed -e '/<\/policymap>/i \ \ <policy domain="delegate" rights="none" pattern="gs" \/>' -i "$pkgdir"/etc/ImageMagick-7/policy.xml
}