summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..019dd4ffcedd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: zach <zach {at} zach-adams {dot} com>
+
+pkgname=imgp-git
+_pkgname=imgp
+_pkgauthor=jarun
+pkgver=117.8412063
+pkgrel=1
+pkgdesc="Resize or rotate JPEG and PNG images."
+arch=('any')
+url="https://github.com/${_pkgauthor}/${_pkgname}"
+license=('GPL3')
+depends=('python3' 'python-pillow')
+makedepends=('git')
+source=(${_pkgname}::"git+https://github.com/${_pkgauthor}/${_pkgname}.git")
+sha256sums=('SKIP')
+conflicts=('imgp')
+provides=('imgp')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" PREFIX="/usr" install
+}