summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d92eb4ff1d0..e74c27521918 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Maintainer: Ramon <https://github.com/ram-on/imgurbash2>
+# Maintainer: Alec Mev <alec@mev.earth>
+# Contributor: NightSong <ramif.47@gmail.com>
pkgname=imgurbash2
-pkgver=3.0
-pkgrel=4
-pkgdesc="A small shell script that uploads/deletes images to/from imgur.com"
+pkgver=3.3
+pkgrel=1
+pkgdesc='A shell script that uploads/deletes images/videos to/from IMGUR'
arch=('any')
-url="https://github.com/ram-on/imgurbash2"
+url='https://github.com/ram-on/imgurbash2'
license=('MIT')
-depends=('curl')
-optdepends=('xsel: automatically putting the URL on the X selection for easy pasting'
- 'xclip: an alternative to xsel')
-source=("https://github.com/ram-on/imgurbash2/archive/${pkgver}.tar.gz")
-sha256sums=('363fbf6e5179dded7504fdc3cc9311e4c9e3e9a91c979fbddba3e4dabd33f6c9')
+depends=('bash' 'curl')
+optdepends=(
+ 'wl-clipboard: To be able to copy image/video URL to clipboard in Wayland'
+ 'xclip: To be able to copy image/video URL to clipboard in X'
+ 'xsel: To be able to copy image/video URL to clipboard in X'
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ram-on/imgurbash2/archive/${pkgver}.tar.gz")
+sha256sums=('7cf9d09fadcf37d47092ed07c554fa55bd21401514cbd2c59d9a88dd78a83f9f')
package() {
- cd "$pkgname-$pkgver"
- install -D -m 755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
- install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 -t "${pkgdir}/usr/bin/" "${pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" examples.md
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}