summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 24 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97c1817849ab..b6444378d758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,31 @@
_pkgname=ImHex
pkgname=${_pkgname,,}
-pkgver=1.31.0
-pkgrel=3
+pkgver=1.32.1
+pkgrel=1
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://imhex.werwolv.net'
license=('GPL2')
arch=('x86_64')
-depends=('glfw' 'mbedtls' 'curl' 'dbus'
+depends=('glfw' 'mbedtls' 'curl' 'dbus' 'libarchive'
'freetype2' 'file' 'hicolor-icon-theme' 'xdg-desktop-portal'
- 'fmt' 'yara')
+ 'fmt' 'yara' 'capstone')
makedepends=('git' 'cmake'
- 'llvm' 'nlohmann-json' 'librsvg'
+ 'llvm' 'librsvg' 'nlohmann-json'
'python' 'cli11' 'dotnet-runtime')
optdepends=('dotnet-runtime: support for .NET scripts')
provides=('imhex-patterns')
conflicts=('imhex-patterns-git')
source=("$pkgname::git+https://github.com/WerWolv/ImHex.git#tag=v$pkgver"
- "nativefiledialog::git+https://github.com/btzy/nativefiledialog-extended.git#commit=800f58283fbc1f3950abd881357fb44c22f3f44e"
+ "nativefiledialog::git+https://github.com/btzy/nativefiledialog-extended.git#commit=5786fabceeaee4d892f3c7a16b243796244cdddc"
"xdgpp::git+https://git.sr.ht/~danyspin97/xdgpp#commit=f01f810714443d0f10c333d4d1d9c0383be41375"
- "libromfs::git+https://github.com/WerWolv/libromfs#commit=80b9adea2003eb01fa4cf2ecb0d77f2d9c0dd32a"
- "capstone::git+https://github.com/capstone-engine/capstone#commit=650e85dcf23b3a3bff69144511533b7339436238"
- "libwolv::git+https://github.com/WerWolv/libwolv#commit=128bed69ea0cf4a904e17f5690aa751b6e4b8568"
+ # "capstone::git+https://github.com/capstone-engine/capstone#commit=097c04d9413c59a58b00d4d1c8d5dc0ac158ffaa"
+ "libromfs::git+https://github.com/WerWolv/libromfs#commit=0a72f7bb33d87c4fb2709b6b94bf83518ab0022d"
+ "libwolv::git+https://github.com/WerWolv/libwolv#commit=d25459dfa8e706af938427e979e454a8326c5984"
"pattern_language::git+https://github.com/WerWolv/PatternLanguage#tag=ImHex-v$pkgver"
"imhex-patterns::git+https://github.com/WerWolv/ImHex-Patterns#tag=ImHex-v$pkgver"
0001-fix-cmake-Fix-when-multiple-.NET-packages-are-instal.patch
- pl-0001-Use-C-23-standard.patch
- pl-0002-makepkg-Remove-extraneous-compiler-flags.patch)
+ 0002-fix-main-Handle-different-LLVM-version.patch)
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -36,10 +35,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '6db78e5899e4ed3eb9170cb30f321706e8f8c7531b38ebf43a1e6595e6f9fc18'
- '9fad69a15f24d932353c1500a885640031699265dcced403d2c8e97e581274e3'
- '1d45242b1090daeec4b028e64598b678a2099af4ec82ab71040082c24520f314')
+ 'f35c206bbda1a3d9a593e09ef30d19f46083d51985088b771e64f36cb6c53666'
+ '436d89ec4a7aea948ccd1cb5d5cc6783079705107c6ad767e8dbe1208d395ed7')
b2sums=('SKIP'
'SKIP'
'SKIP'
@@ -47,21 +44,22 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'd393cc7a6aa26fabac6ede2e435b6df1a334c74ba981af902bcfbb77841f89dba2f110c7e025ef20a808d10fda4865c7d1ed28a39debccb1e1f797765c7bb1ee'
- 'd9967d5d82b3457fe3065dd3aa69887a4f07d2c74afd686250065bf438677e1b26801c9d2b5795003b22c1224c4447864559248a29bfd34a9af2bb637bc1d515'
- '4b38b83a9c70a05f119e2d7704ca0721ac755dda05f1f23f81e5c2d41751ea2db8212b537db133d5ab75eee7c858f103ca5825ab182b3b53c35e59278fbed527')
+ 'd67844dccd070ba302599c85e9a7c5269fa1d6d592b3919148f13a640ac1bd002103b75c8a721c9de40d0a96c3169ef383fe59f96d43bb5bb6f3e573ca39c5fa'
+ '90c1872766e16e76509b378437ceb8f8f0638c31cbacba29fc153a4a9046b79af1083751a8a1f73c42662bf2bf2484601c4dc4533bdf4fc0b40c4306b98a1c78')
options=(!lto !strip)
prepare() {
cd "$pkgname"
git submodule init
- for name in nativefiledialog xdgpp libromfs capstone libwolv pattern_language; do
+ for name in nativefiledialog xdgpp; do
+ git config submodule.lib/third_party/$name.url "$srcdir/$name"
+ done
+ for name in libromfs libwolv pattern_language; do
git config submodule.lib/external/$name.url "$srcdir/$name"
done
- for name in fmt yara/yara; do
- git config --remove-section submodule.lib/external/$name
+ for name in capstone fmt yara/yara; do
+ git config --remove submodule.lib/third_party/$name
done
git -c protocol.file.allow=always submodule update
@@ -73,11 +71,8 @@ prepare() {
submodule update
git apply \
- "$srcdir/0001-fix-cmake-Fix-when-multiple-.NET-packages-are-instal.patch"
-
- git -C lib/external/pattern_language apply \
- "$srcdir/pl-0001-Use-C-23-standard.patch" \
- "$srcdir/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch"
+ "$srcdir/0001-fix-cmake-Fix-when-multiple-.NET-packages-are-instal.patch" \
+ "$srcdir/0002-fix-main-Handle-different-LLVM-version.patch"
}
build() {
@@ -97,7 +92,8 @@ build() {
-D USE_SYSTEM_YARA=ON \
-D USE_SYSTEM_FMT=ON \
-D USE_SYSTEM_NLOHMANN_JSON=ON \
- -D USE_SYSTEM_CAPSTONE=OFF \
+ -D USE_SYSTEM_CAPSTONE=ON \
+ -D USE_SYSTEM_CLI11=ON \
-D IMHEX_VERSION="$pkgver"
cmake --build build