summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9454e0afc6f..1e03c11e93d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=ImHex
pkgname=${_pkgname,,}
pkgver=1.10.1
-pkgrel=2
+pkgrel=3
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://github.com/WerWolv/ImHex'
license=('GPL2')
@@ -17,26 +17,30 @@ source=("$pkgname::git+https://github.com/WerWolv/ImHex.git#tag=v$pkgver"
"nativefiledialog::git+https://github.com/btzy/nativefiledialog-extended.git"
"git+https://git.sr.ht/~danyspin97/xdgpp"
imhex.desktop
- 0001-Fix-raised-exception-when-a-pattern-directory-does-n.patch
- 0002-Fix-infinite-loop-on-signal-handling.patch)
+ 0001-Fix-crash-on-pattern-load-319.patch
+ 0002-patterns-Limit-number-of-characters-displayed-in-a-s.patch
+ 0003-Fix-infinite-loop-on-signal-handling.patch)
cksums=('SKIP'
'SKIP'
'SKIP'
'4178124713'
- '229967015'
- '1954423175')
+ '3591955572'
+ '35583119'
+ '1275958398')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'72525512a241589cecd6141f32ad36cbe1b5b6f2629dd8ead0e37812321bdde6'
- '5db9f458a36777333d7b3302249c90f82338f4d4f6dd0366e9b005c15034c388'
- '5438cc0ee91933584d678dd3fea5ad0cbe15f4bd7ac1cebb572a28b7479d86df')
+ 'cbe6a0f3623503be2c57905a2ed405ae3001ff5d8a8a708492f488f89672726c'
+ 'ba9794ebef4cec1085fe597f6b6e997e85ca9d839b084722729c7471d1117383'
+ '43a3ad9a9bc05382dde3da52d6f065f0c770457e47629eb0363eb6968fa317c4')
b2sums=('SKIP'
'SKIP'
'SKIP'
'7b2d029de385fdc2536f57a4364add9752b9a5dc31df501e07bff1fd69fdd1de2afa19a5ac5a4c87fbf21c5d87cc96d3fe30d58825c050f5a7d25f6d85d08efc'
- 'c2a86c31a33cfe40a379dd43fcb9c4c8105a23cd26721183d1207021b93a1d9aeb8abdeb873dc40dacd31896da844b84d0a8884c7819581a1c13d489d8c96f44'
- '81b3d264ef7443fa63e2e40cd4883c1f137cc7fc4423d66210d06fb4fcfe30d09de3ccf60db75d1e74e7c5039c4fc47e501b38a4b8169f054ccab1587eca07c6')
+ '761635626e86b05bb03584219ef38e12abec1d2ef9dc78453ae0304fcbedbaa7c8f4859e5db8b89e08104bc94bcdd10d22de318628725cb8a0bde099f9a8ea25'
+ 'b83335ebf63db82605aac11b26fe87a09db8bd6b80d780bda168c10df6669c31554b6919c53b46db664a3f6f0748d220d007042fb7b2c20743581c6b64217c90'
+ '8ffcb4fe81d5290a53d95498ae64c18f158fc4312140d6ae23bd802ee5346de477c4c9fa2adc0db039dd1c2733d8268294dcee82c81066aac8d4e3018a6607dd')
prepare() {
cd "$pkgname"
@@ -51,8 +55,9 @@ prepare() {
git submodule update
git apply \
- "$srcdir/0001-Fix-raised-exception-when-a-pattern-directory-does-n.patch" \
- "$srcdir/0002-Fix-infinite-loop-on-signal-handling.patch"
+ "$srcdir/0001-Fix-crash-on-pattern-load-319.patch" \
+ "$srcdir/0002-patterns-Limit-number-of-characters-displayed-in-a-s.patch" \
+ "$srcdir/0003-Fix-infinite-loop-on-signal-handling.patch"
}
build() {