summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 304559ab5fb9..c9d2d2cac125 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=ImHex
pkgname=${_pkgname,,}
-pkgver=1.27.1
+pkgver=1.28.0
pkgrel=1
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://imhex.werwolv.net'
@@ -21,6 +21,7 @@ source=("$pkgname::git+https://github.com/WerWolv/ImHex.git#tag=v$pkgver"
"xdgpp::git+https://git.sr.ht/~danyspin97/xdgpp"
"libromfs::git+https://github.com/WerWolv/libromfs"
"capstone::git+https://github.com/capstone-engine/capstone#branch=next"
+ "libwolv::git+https://github.com/WerWolv/libwolv"
"pattern_language::git+https://github.com/WerWolv/PatternLanguage#tag=ImHex-v$pkgver"
0001-makepkg-Fix-compiler-check.patch
pl-0001-Use-C-23-standard.patch
@@ -31,25 +32,27 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'b85e294923db8ef8688e388800ebc384fe75da3cfad13029e421d858f7ec9fc4'
- '220c8477d1dbdd9ae34f438aec63cca2d8431d012a82873bd648b5c9d396c3c1'
- 'cf24fc2ae2e4fd72afac855f66f39ee6ea8ca4a551f2ec6671ddd611daa49a3a')
+ 'SKIP'
+ '43bdbbb6edf567201fa52f1c695f77fea9a27dd5c62de615ef74d64a5e676a98'
+ '4c3e667d40eabe2a5ea724125c69f73bcb6774c01db9ad97bc6b633e1c284fc5'
+ '7a7f17c95bfe9de4cda023aa29dfa019ea2870c29e14fa559c2be8b725649d57')
b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- '02f273787f1dd80ca52490d0ae342579356f9d366306ae78777df2821dfba79883535091c221d79a721cdb155d71686f3a0126e2c0a7ceff1df47c87fbad6f87'
- '2f54ec7342b7c43c443d45bfba2bb74e2b7fbc190d89d2cb529ff51cb4bbd9e7a61e141b9414fce11900e173a305a0a9edd510f0c5ba965e7f804193238ef8a7'
- '2ccfa6f03521e70f6fa6d6e09597bb01214d8d367d27a6aeee49b235cb078c8c59ef03be1a7971687e2503c743d5767e6e23df4108be33d02013b2c542f5f459')
+ 'SKIP'
+ '99e8c5fb5dc0ad07039731c3245bec097de25e675be0f5c52c799738d794ee26df6506adf34fac42663dd39f1c84e7e1675aac5b2f47ef4f2d5ebb903ad4b3a3'
+ 'ca3779e974709fa15e55255973eb2ff34fb21251c9f8b00c5b2efcfb175add34b503063984589c8d716b650a9543aa19dc2185b2f531ab8d4363635724114199'
+ 'cc2c7d42f18bfb5da0c962b1f3a98c19aec541df9464a3a7a4ac118def9f81e41ac38967c95aba1bc17b3b48630dcef5c9c51bbaf8eed4f386c9aa46a21d2d78')
options=(!lto !strip)
prepare() {
cd "$pkgname"
git submodule init
- for name in nativefiledialog xdgpp libromfs capstone pattern_language; do
+ for name in nativefiledialog xdgpp libromfs capstone libwolv pattern_language; do
git config submodule.lib/external/$name.url "$srcdir/$name"
done
for name in fmt curl yara/yara; do
@@ -57,6 +60,13 @@ prepare() {
done
git -c protocol.file.allow=always submodule update
+ for name in libwolv; do
+ git -C lib/external/pattern_language \
+ config submodule.external/$name.url "$srcdir/$name"
+ done
+ git -C lib/external/pattern_language -c protocol.file.allow=always \
+ submodule update
+
git apply \
"$srcdir/0001-makepkg-Fix-compiler-check.patch"