summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f60aa2784c7a..588106e42510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,10 @@ license=('BSD')
depends=('tk' 'tcllib' 'wireshark-gtk' 'imagemagick' 'docker' 'openvswitch' 'xterm')
makedepends=('make')
provides=('imunes')
-source=('git+https://github.com/imunes/imunes.git')
-sha1sums=('SKIP')
+source=('git+https://github.com/imunes/imunes.git'
+ '0001-PKGBUILD-compat.patch')
+sha1sums=('SKIP'
+ 'ba1dbc566f352e3faeed62bc3561f3f01265c777')
_gitname=imunes
pkgver() {
@@ -22,16 +24,12 @@ pkgver() {
prepare() {
cd $_gitname
sed -i "s,ROOTDIR=\"/usr/local\",ROOTDIR=\"${pkgdir}/usr\"," scripts/update_version.sh
-}
-
-build() {
- echo "No Build"
- echo "${pkgdir}"
+ patch -p1 -i $srcdir/0001-PKGBUILD-compat.patch
}
package() {
cd $_gitname
- make PREFIX=${pkgdir}/usr install
+ make PREFIX=${pkgdir}/usr REALPREFIX=/usr install
}
# vim:set ts=2 sw=2 et: