summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ebf6557fc72d..e8c483216b75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Contributor: Ainola
pkgname=imv-git
-pkgver=v2.1.3.r202.ge278e28
+pkgver=v2.1.3.r300.ge0e019c
pkgrel=1
pkgdesc='imv is a command line image viewer intended for use with tiling window managers, with Wayland and X11 support.'
url="https://github.com/eXeC64/imv"
arch=('x86_64' 'i686')
license=('MIT')
-depends=('freeimage' 'sdl2_ttf' 'fontconfig')
-makedepends=('git' 'asciidoc')
+depends=('libxkbcommon-x11' 'freeimage' 'librsvg' 'desktop-file-utils')
+makedepends=('git' 'asciidoc' 'cmocka')
+optdepends=('wayland' 'egl-wayland')
provides=('imv')
conflicts=('renameutils' 'imv')
source=("git+https://github.com/eXeC64/imv.git")
@@ -24,6 +25,11 @@ build() {
make -C imv BUILDDIR=build
}
+check() {
+ make check -C imv BUILDIR=build
+}
+
package() {
make -C imv BUILDDIR=build DESTDIR="$pkgdir" install
+ install -Dm644 $srcdir/imv/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}