summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..928892f52a79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Copyright (C) 2020 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+_pkgname=imx_usb_loader
+pkgname=${_pkgname}-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="Tool to communicate with I.MX bootroms to execute code"
+arch=('armv7h' 'i686' 'x86_64')
+url='https://github.com/boundarydevices/imx_usb_loader'
+license=('LGPL')
+depends=('libusb')
+makedepends=('git')
+_commit=('30b43d69770cd69e84c045dc9dcabb1f3e9d975a')
+source=("git://github.com/boundarydevices/imx_usb_loader.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ make
+}
+
+package(){
+ cd "$srcdir/${_pkgname}"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}