summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 26 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 057e9b9c00a1..56bea1d738e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
-# Maintainer: David Schury <dasc at posteo de>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: David Schury <dasc at posteo de>
# Contributor: reMiND <detanator_at_gmail_com>
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
# Contributor: trile7 at gmail dot com
-pkgname=inadyn-fork
_name=inadyn
-pkgver=1.99.15
+pkgname=inadyn-fork
+pkgver=2.1
pkgrel=1
-pkgdesc='Simple dynamic DNS client - fork of the original INADYN implementation from Narcis Ilisei'
-url='http://troglobit.com/inadyn.html'
-arch=('x86_64' 'i686' 'armv6h' 'armv7h')
+pkgdesc="Dynamic DNS client with SSL/TLS support"
+arch=('i686' 'x86_64')
+url="http://troglobit.com/inadyn.html"
license=('GPL')
-depends=('openssl')
-backup=('etc/inadyn.conf')
-conflicts=('inadyn-opendns' 'inadyn' 'inadyn-mt' 'inadyn-fork-git')
+#depends=('ca-certificates' 'confuse' 'openssl')
+depends=('ca-certificates' 'confuse' 'libite' 'openssl')
provides=('inadyn')
-source=(https://github.com/troglobit/inadyn/releases/download/$pkgver/${_name}-$pkgver.tar.xz
- inadyn.conf
- inadyn.service)
-sha256sums=('b54ed82653e9bd6624e579433907aecfd3e83bdab9ed0b3c21d6817c799ac715'
- '2da656ca5b971484c7e033e9e9bcd26afbf4fa08f707f7ca44d954d1646353d7'
- '4587f4ae2a4215f9ba67d5b3b7d0aa120a9ebd31677472fa68d8792f42d7135f')
+backup=('etc/inadyn.conf')
+source=(https://github.com/troglobit/inadyn/releases/download/v$pkgver/$_name-$pkgver.tar.xz
+ inadyn.conf)
+sha256sums=('87639a7c1ddc047074601ad60188279a2a0d9393367f046c153de0e24586b3ac'
+ '4967d5fad250f38167b78c53862674afec7851f7c7bb648d00afe34db062bc60')
-build(){
- cd ${_name}-$pkgver
- ./configure --prefix=/usr --sbindir=/usr/bin --enable-openssl
- export prefix=/usr # libite needs this
+build() {
+ cd $_name-$pkgver
+ ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --enable-openssl
make
}
-package(){
- cd ${_name}-$pkgver
- make DESTDIR=$pkgdir install
- install -Dm644 ../inadyn.service $pkgdir/usr/lib/systemd/system/inadyn.service
- install -Dm600 ../inadyn.conf $pkgdir/etc/inadyn.conf
+package() {
+ install -Dm600 inadyn.conf "$pkgdir/etc/inadyn.conf"
+
+ cd $_name-$pkgver
+ #install -Dm644 examples/dyndns.conf "$pkgdir/usr/share/inadyn/examples/dyndns.conf"
+ #install -Dm644 examples/freedns.conf "$pkgdir/usr/share/inadyn/examples/freedns.conf"
+ #install -Dm644 examples/custom.conf "$pkgdir/usr/share/inadyn/examples/custom.conf"
+ make DESTDIR="$pkgdir" install
}
+