summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 27 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92378098efec..9ca9472d7209 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ set -u
_pkgname='inetutils'
pkgname="${_pkgname}-git"
pkgver=1.9.4.r42.ga4a331b7
-pkgrel=2
+pkgrel=3
_srcdir="${_pkgname}"
pkgdesc='A collection of common network programs'
arch=('i686' 'x86_64')
@@ -19,7 +19,7 @@ makedepends=('help2man' 'git' 'autoconf')
provides=("${_pkgname}=${pkgver%%.r*}")
conflicts=("${_pkgname}")
backup=('etc/xinetd.d'/{telnet,talk,rlogin,rsh}
- 'etc/pam.d'/{rlogin,rsh})
+ 'etc/pam.d'/{rlogin,rsh,telnetd})
options=('!emptydirs' '!strip')
install="${_pkgname}.install"
_verwatch=('http://ftp.gnu.org/gnu/inetutils/' 'inetutils-\([0-9\.]\+\)\.tar\.gz' 'l')
@@ -27,6 +27,7 @@ source=(
"git://git.savannah.gnu.org/${_pkgname}.git" #commit=3d64a8c7280e7d218c4b607aa25352be1d6c4ded"
'git://git.sv.gnu.org/gnulib'
'0001-telnetd-Fix-buffer-overflows.patch'
+ 'telnetd.pam' # for now this overwrites /etc/pam.d/other until a better way or pam patch is found
) # This link must be the same as the one in bootstrap
_archlink="@@@::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/@@@?h=packages/${_pkgname}"
_archsource=(
@@ -43,6 +44,7 @@ unset _src _archlink
md5sums=('SKIP'
'SKIP'
'a902f8c38f6db36574b928e41d2d2814'
+ '6e6c8719e5989d976a14610f340bd33a'
'fe181e22d3544456f52e64f3bdf5f291'
'cda2aa3cd2353120b142fd33b3b4f4df'
'7cea13f4ff7fd170fc4d03ef2698200d'
@@ -61,6 +63,7 @@ md5sums=('SKIP'
sha256sums=('SKIP'
'SKIP'
'09210d3e7799fe93c712a0540f74ba281c61499a47af53e308ee6c3c3367b4dc'
+ 'de66118684a2ecec18017dd96e50a489f30465510250c007ced16f81fb542ba5'
'f1b9b4e57f484070366444a649f1be151d01d5bc965b9b192c242e4b7cc4beeb'
'428367b148033c7fa865e92bdd73b06cb58e6909488649adebf8d2253a022f1f'
'6112bcdb595937a8c7940dc158a97fd48b8cce6526a9fb017f347f614b9d6548'
@@ -205,7 +208,28 @@ Depends = coreutils
When = PostTransaction
Exec = /usr/bin/bash "${_script}"
EOF
- ) "${pkgdir}/usr/share/libalpm/hooks/${pkgname}-foomatic-db.hook"
+ ) "${pkgdir}/usr/share/libalpm/hooks/${pkgname}-readline.hook"
+
+ # Crude but effective method for fixing pam unaware application
+ install -Dm644 <(cat << EOF
+# Automatically generated by ${pkgname}-${pkgver} PKGBUILD from Arch Linux AUR
+# https://aur.archlinux.org/
+
+# Update /etc/pam.d/other for ${pkgname} on each upgrade of pambase
+
+[Trigger]
+Operation = Upgrade
+Type = Package
+Target = pambase
+
+[Action]
+Description = Update /etc/pam.d/other for ${pkgname}
+Depends = coreutils
+When = PostTransaction
+Exec = /usr/bin/cp -p /etc/pam.d/telnetd /etc/pam.d/other
+EOF
+ ) "${pkgdir}/usr/share/libalpm/hooks/${pkgname}-pambase-other.hook"
+ install -Dpm644 "${srcdir}/telnetd.pam" "${pkgdir}/etc/pam.d/telnetd"
set +u
}
set +u