summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c94cccea4a7..6850c3f3b1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
pkgname=inform7-git
_gitpkg=inform
-_mirror="https://ifarchive.org"
pkgver=r1395.6ff3fd8db
-pkgrel=1
+pkgrel=2
pkgdesc="A design system for interactive fiction based on natural language (git version)"
arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'pentium4' 'x86_64')
url="https://ganelson.github.io/inform"
@@ -12,6 +11,7 @@ license=('Artistic2.0')
provides=('inform' 'inform7')
conflicts=('inform7')
groups=(inform)
+install=inform7.install
source=('git+https://github.com/ganelson/inform'
'git+https://github.com/ganelson/inweb'
@@ -22,8 +22,8 @@ source=('git+https://github.com/ganelson/inform'
md5sums=('SKIP'
'SKIP'
'SKIP'
- '97f4a478c9055ef8adc0717b6c23b1af'
- 'ddac46959271ebb9fbd31341b7ebd1af')
+ 'e068ffd6869177fae89a34dbe96bdf5d'
+ '88a7cefc597fdc719866b72c256166c6')
pkgver() {
cd "${_gitpkg}"
@@ -49,8 +49,5 @@ package() {
cd "${srcdir}"
cp -a dist/* "${pkgdir}"
- # moving inform7 binary here for now
- mv "${pkgdir}"/usr/bin/inform7 "${pkgdir}/usr/share/inform7"
-
install -Dm755 wrapper.sh "${pkgdir}/usr/bin/inform7"
}