summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 16 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1a288d06757..458482f209cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: metamer <metamer at openmailbox dot org>
+#Maintainer: metamer <metamer at openmailbox dot org>
pkgname=infra-arcana
-pkgver=18.2
+pkgver=19.0
pkgrel=1
epoch=
pkgdesc="Roguelike game inspired by H.P. Lovecraft"
@@ -8,63 +8,59 @@ arch=('i686' 'x86_64')
url="https://sites.google.com/site/infraarcana/home"
license=('custom:Infra Arcana License')
groups=()
+makedepends=(cmake)
depends=('sdl2_image' 'sdl2_mixer' 'hicolor-icon-theme')
#checkdepends=('valgrind')
backup=()
options=()
install=${pkgname}.install
-source=( "git+https://github.com/martin-tornqvist/ia.git"#"tag=v${pkgver}"
- "rl-utils-numeric-include.patch"
- "room-numeric-include.patch"
+source=( git+"https://github.com/martin-tornqvist/ia.git"#"tag=v${pkgver}"
"${pkgname}.install"
"${pkgname}.desktop"
"${pkgname}.sh")
md5sums=('SKIP'
- 'fd8cacaa622c4363787cff2e575a8938'
- '3c05836d84ad451d5d8034267b21ade8'
'2bc0fb64e8593e25009b1dc50e642cd8'
'2e28c2803d7d2cd4376dcd3aa6512774'
'87294b81f5a2f98a78d318a5dcec7caf')
prepare(){
cd $srcdir/"ia"
- cd src
- patch -uN room.cpp $srcdir/room-numeric-include.patch
- cd $srcdir/"ia"
git submodule init
git submodule update
- cd rl_utils/src
- patch -uN rl_utils.cpp $srcdir/rl-utils-numeric-include.patch
}
build() {
cd $srcdir/"ia"
+ mkdir -p build && cd build
+ cmake ..
make
}
package() {
cd "ia"
#install licenses
- install -DTm644 "target/license.txt"\
+ install -DTm644 "build/res/license.txt"\
"${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
- install -DTm644 "target/images/SPECIAL_ELITE_License.txt" \
+ install -DTm644 "build/res/images/SPECIAL_ELITE_License.txt" \
"${pkgdir}/usr/share/licenses/${pkgname}/SPECIAL_ELITE_License.txt"
#install docs
- install -DTm644 "target/contact.txt" \
+ install -DTm644 "build/res/contact.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/contact.txt"
- install -DTm644 "target/credits.txt" \
+ install -DTm644 "build/res/credits.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/credits.txt"
- install -DTm644 "target/manual.txt" \
+ install -DTm644 "build/res/manual.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/manual.txt"
- install -DTm644 "target/release_history.txt" \
+ install -DTm644 "build/res/release_history.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/release_history.txt"
#make dir for save game storage
mkdir -p "${pkgdir}/var/lib"
install -dm775 -g games "${pkgdir}/var/lib/${pkgname}"
install -dm775 -g games "${pkgdir}/var/lib/${pkgname}/data"
- #move target
+ #move res
mkdir -p "${pkgdir}/opt/${pkgname}/"
- cp -R target/* "${pkgdir}/opt/${pkgname}/"
+ cp -R build/res "${pkgdir}/opt/${pkgname}/"
+ # copy main binary
+ cp build/ia "${pkgdir}/opt/${pkgname}/"
#link savegame folder
rm -rf "${pkgdir}/opt/${pkgname}/data"
ln -s "/var/lib/${pkgname}/data" "${pkgdir}/opt/${pkgname}"