summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 22 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2af442b227a0..31e820ca1c07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,33 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=intel-graphics-compiler-git
-pkgver=2019.02.25.r44.g4be564f
+pkgver=2019.03.12.r40.g49497e5
pkgrel=1
pkgdesc='Intel Graphics Compiler for OpenCL (git version)'
arch=('x86_64')
url='https://github.com/intel/intel-graphics-compiler/'
license=('MIT')
-depends=('gcc-libs' 'zlib')
-makedepends=('git' 'cmake' 'libxml2' 'python-nose' 'python2' 'python2-pygments'
- 'python2-yaml')
+depends=('llvm-libs')
+makedepends=(
+ # official repositories:
+ 'git' 'cmake' 'clang' 'llvm' 'zlib' 'python2'
+ # AUR:
+ 'opencl-clang-git'
+)
provides=('intel-graphics-compiler')
conflicts=('intel-graphics-compiler' 'compute-runtime')
options=('!emptydirs')
-source=('igc'::'git+https://github.com/intel/intel-graphics-compiler.git'
- 'llvm_patches'::'git+https://github.com/intel/llvm-patches.git'
- 'llvm_source'::'git+https://github.com/llvm-mirror/llvm.git#branch=release_70'
- 'git+https://github.com/llvm-mirror/clang.git#branch=release_70'
- 'git+https://github.com/intel/opencl-clang.git#branch=ocl-open-70'
- 'git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_70')
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+source=('git+https://github.com/intel/intel-graphics-compiler.git')
+sha256sums=('SKIP')
prepare() {
mkdir -p build
- ln -sf "${srcdir}/clang" llvm_source/tools/clang
- ln -sf "${srcdir}/opencl-clang" llvm_source/projects/opencl-clang
- ln -sf "${srcdir}/SPIRV-LLVM-Translator" llvm_source/projects/llvm-spirv
-
- # for applying patches from llvm-patches
- local _dir
- for _dir in clang SPIRV-LLVM-Translator
- do
- cd "$_dir"
- git config --local commit.gpgsign false
- git config --local user.email 'aur@localhost.none'
- git config --local user.name 'Arch User Repository (AUR)'
- cd ..
- done
+ ln -sf intel-graphics-compiler igc
}
pkgver() {
- cd igc
+ cd intel-graphics-compiler
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^igc_release_//'
@@ -56,15 +37,19 @@ build() {
cd build
cmake \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_LIBDIR:PATH='lib' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DIGC_OPTION__OUTPUT_DIR='../igc-install/Release' \
+ -DVME_TYPES_DEFINED='FALSE' \
-Wno-dev \
- ../igc/IGC
+ ../igc
make
-
+
# license
- sed -n '2,20p' igc.opencl.h > LICENSE # create file
- sed -i '1,22s/^.\{,3\}//' LICENSE # erase C comments
+ sed -n '2,20p' IGC/AdaptorOCL/igc.opencl.h > LICENSE # create file
+ sed -i '1,22s/^.\{,3\}//' LICENSE # erase C comments
}
package() {
@@ -72,5 +57,7 @@ package() {
make DESTDIR="$pkgdir" install
+ rm "${pkgdir}/usr/lib/libopencl_clang.so"
+
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}