summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fe2482739e1..007e29c704af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,30 @@
pkgname=intel-svt-hevc
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='An HEVC-compliant encoder for Intel CPUs of 5th Generation (Broadwell) and above'
arch=('x86_64')
url='https://github.com/OpenVisualCloud/SVT-HEVC/'
license=('BSD')
depends=('gcc-libs')
makedepends=('cmake' 'yasm')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/OpenVisualCloud/SVT-HEVC/archive/v${pkgver}.tar.gz")
-sha256sums=('ef21f3a13e33b4f61af4a0c79337ce9e4f73f6fe13d1c2afe2c3b0712f4158d9')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/OpenVisualCloud/SVT-HEVC/archive/v${pkgver}.tar.gz"
+ 'intel-svt-hevc-fix-build-on-non-intel.patch')
+sha256sums=('ef21f3a13e33b4f61af4a0c79337ce9e4f73f6fe13d1c2afe2c3b0712f4158d9'
+ 'e18d5cba469242e35fcbf285a3f05cd954d27b3243c8760333c5487b60e55132')
prepare() {
cd "SVT-HEVC-${pkgver}"
mkdir -p build
+
+ # hack: fix build on non-intel cpu
+ local _cpu_vendor
+ _cpu_vendor="$(awk -F':' '/vendor_id/ { gsub(" ", "", $2); print $2 }' /proc/cpuinfo | uniq)"
+ if [ "$_cpu_vendor" != 'GenuineIntel' ]
+ then
+ patch -Np1 -i "${srcdir}/intel-svt-hevc-fix-build-on-non-intel.patch"
+ fi
}
build() {