summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01361861b355
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Francisco Lopes <francisco+interception@nosubstance.me>
+pkgname=interception-xswitch
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='xswitch: an Interception Tools tool to redirect stdin to a muxer if a X window matches'
+arch=('x86_64')
+license=('MIT')
+url='https://gitlab.com/interception/linux/plugins/xswitch'
+depends=('interception-tools' 'glibc' 'libx11' 'libxmu')
+makedepends=('boost' 'cmake' 'gcc')
+source=("$pkgname.tar.gz::https://gitlab.com/interception/linux/plugins/xswitch/repository/archive.tar.gz?ref=v${pkgver}")
+sha256sums=('8bb49502179b6433e43fcc7051f5aad52695cee70b5bdab59818719d64682690')
+
+build() {
+ cd ${srcdir}/xswitch-v${pkgver}-*
+ cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
+}
+
+package() {
+ cd ${srcdir}/xswitch-v${pkgver}-*/build
+
+ make DESTDIR="$pkgdir/" install
+}