summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3909c856a8d..d353c1c44ae2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: mutantmonkey <aur@mutantmonkey.mx>
pkgname=intiface-desktop
-pkgver=20.0.0
-pkgrel=2
+pkgver=21.0.0
+pkgrel=1
pkgdesc="Open-source, cross-platform application that acts as a hub for sex hardware access"
depends=('electron')
makedepends=('npm' 'yarn' 'git' 'trash-cli' 'typescript')
@@ -11,17 +11,10 @@ url="https://intiface.com/desktop/"
license=('BSD')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/intiface/intiface-desktop/archive/v${pkgver}.tar.gz"
'intiface-desktop.sh'
- 'intiface-desktop.desktop'
- 'core_isonline_fix.patch')
-sha256sums=('9402de0e8aa9b969ae90538ef96e7df3b6252dec73f14f0c2105c5381976b6d2'
+ 'intiface-desktop.desktop')
+sha256sums=('e39e65b302215ee58ebd13a0a234049ca6fb0bf7d73b817ba64ca9089cfaea2f'
'2f7d3350631fda4da8f03938eb06b0b6d3ed571c9975906b7863298f75e4c73f'
- 'ece9fd45978dae583a9c572f3e64f8234350d5e53f9c1ae2da503c53b3ecff64'
- '0060f45c1036f19955940f843d52c820a50cb9f362e3ad91ab0eb13a8d6e525c')
-
-prepare() {
- cd "${pkgname}-${pkgver}"
- patch -p1 -i ../core_isonline_fix.patch
-}
+ 'ece9fd45978dae583a9c572f3e64f8234350d5e53f9c1ae2da503c53b3ecff64')
build() {
cd "${pkgname}-${pkgver}"
@@ -36,6 +29,9 @@ build() {
cd ../core
yarn
yarn build
+ cd ../core-backend
+ yarn
+ yarn build
cd ../intiface
yarn
yarn electron:build --publish never