summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a8b9ca28592
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Olivier Mehani <olivier.mehani@inria.fr>
+# $Id$
+# Mostly based on the Gentoo ebuild
+# http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild?rev=1.3&view=markup
+
+pkgname=ipkg-utils
+pkgver=050831
+pkgrel=1
+pkgdesc="The Itsy Package Management System utils"
+url="http://handhelds.org/moin/moin.cgi/Ipkg"
+source=(http://www.handhelds.org/download/packages/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ipkg-utils-050831.destdir.patch)
+makedepends=(python)
+md5sums=('4ede7edd4bcb69d9a0b74af2f68fd6da'
+'f53ad35c8ea36dd42aeb2edf0c81df34')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np1 < $startdir/src/ipkg-utils-050831.destdir.patch
+ make || exit 2
+
+ mkdir -p $startdir/pkg/usr/bin
+ make DESTDIR=$startdir/pkg PREFIX=/usr install || exit 3
+}