summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7df81e11fc62..6b52078158ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,11 @@ makedepends=('git' 'libtool' 'gcc' 'gzip' 'gawk' 'sed')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
install="${pkgname}.install"
+# define 'lts' for linux-lts package
_linux_custom="ARCH"
-_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-(.*)-'${_linux_custom}'\/$/ {print $2}'`"
+# define '-lts' for linux-lts package
+_linux_localversion=""
+_kernver="`pacman -Ql linux${_linux_localversion} | awk '/(\/modules\/)([0-9.-])+-(.*)-'${_linux_custom}'\/$/ {print $2}'`"
pkgver() {
cd "${srcdir}/${pkgname}"