summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72df5917a3de..38775e6faba5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,27 @@
_pkgbase=iptables
pkgbase=iptables-fullconenat
pkgname=(iptables-fullconenat iptables-fullconenat-nft)
-pkgver=1.8.3
-pkgrel=1
+pkgver=1.8.10
+pkgrel=3
epoch=1
pkgdesc='Linux kernel packet control tool with FULLCONENAT support.'
arch=(x86_64)
-license=(GPL2)
+license=('GPL-2.0-only')
url='https://www.netfilter.org/projects/iptables/index.html'
-depends=(libnftnl libpcap libnfnetlink libnetfilter_conntrack bash netfilter-fullconenat-dkms-git)
+depends=(libnftnl libpcap libnfnetlink libnetfilter_conntrack bash)
makedepends=(linux-api-headers)
+optdepends=("netfilter-fullconenat: kernel module for fullconenat")
provides=('iptables')
+conflicts=(iptables)
install=${pkgbase}.install
backup=(etc/ethertypes etc/iptables/{ip,ip6}tables.rules)
-source=(https://www.netfilter.org/projects/iptables/files/$_pkgbase-$pkgver.tar.bz2{,.sig}
+source=(https://www.netfilter.org/projects/iptables/files/$_pkgbase-$pkgver.tar.xz{,.sig}
empty.rules simple_firewall.rules empty-{filter,mangle,nat,raw,security}.rules
{arp,eb,ip,ip6}tables.service iptables-{legacy,nft}-flush
- "libipt_FULLCONENAT.c::https://raw.githubusercontent.com/Chion82/netfilter-full-cone-nat/master/libipt_FULLCONENAT.c")
-sha1sums=('6df99e90cb4d59032ab2050ebb426fe065249bd3'
+ iptables-apply-default-path.patch
+ "libipt_FULLCONENAT.c::https://raw.githubusercontent.com/llccd/netfilter-full-cone-nat/dev/libipt_FULLCONENAT.c"
+ "libip6t_FULLCONENAT.c::https://raw.githubusercontent.com/llccd/netfilter-full-cone-nat/dev/libip6t_FULLCONENAT.c")
+sha1sums=('ddbebf81eacbf900dc6dd4ed409353930397e0c2'
'SKIP'
'83b3363878e3660ce23b2ad325b53cbd6c796ecf'
'f085a71f467e4d7cb2cf094d9369b0bcc4bab6ec'
@@ -34,16 +38,24 @@ sha1sums=('6df99e90cb4d59032ab2050ebb426fe065249bd3'
'9cec592787e32451f58fa608ea057870e07aa704'
'd10af7780d1634778d898c709e2d950aa1561856'
'15c1684f3e671f4d0ede639a7c9c08e1a841511c'
- 'b5dd6f51b9257150290a140453e09d38fb63c391')
-validpgpkeys=('C09DB2063F1D7034BA6152ADAB4655A126D292E4') # Netfilter Core Team
+ '454d0a6d3bca14b8702e7c5e2672f5bc0c832b85'
+ '1d320a1193a754d5cb4afa7c4b8bb27316c7dd95'
+ 'abec6a9a953101c0345d60e5812393243cc7bb7b')
+validpgpkeys=('C09DB2063F1D7034BA6152ADAB4655A126D292E4'
+ '37D964ACC04981C75500FB9BD55D978A8A1420E4') # Netfilter Core Team
prepare() {
mkdir build
cd $_pkgbase-$pkgver
- cp ../libipt_FULLCONENAT.c extensions/
+ cp ../libip{,6}t_FULLCONENAT.c extensions/
# use system one
rm include/linux/types.h
+
+ ln -rs libiptc/linux_list.h include/libiptc
+
+ # use Arch path
+ patch -p0 -i ../iptables-apply-default-path.patch
}
build() {
@@ -69,8 +81,8 @@ package_iptables-fullconenat() {
package_iptables-fullconenat-nft() {
pkgdesc+=' (using nft interface)'
depends+=(nftables)
- provides=(iptables arptables ebtables)
- conflicts=(iptables arptables ebtables)
+ provides=(iptables iptables-fullconenat arptables ebtables)
+ conflicts=(iptables iptables-fullconenat arptables ebtables)
backup+=(etc/{arp,eb}tables.conf)
_package nft