summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c00f0cc1598
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=iris-flower
+pkgver=1.0
+pkgrel=1
+pkgdesc="Eye protection utility. Change brightness, color temperature and color scheme on X11"
+arch=('i686' 'x86_64')
+url="https://github.com/ueberchild/iris-flower"
+license=('GPL3')
+depends=('libx11' 'libxrandr')
+source=("https://github.com/ueberchild/iris-flower/blob/master/iris-flower.c")
+
+build() {
+ cd "$srcdir/"
+ cc -Wall -std=c99 -o iris-flower iris-flower.c -lX11 -lXrandr
+}
+
+package() {
+ cd "$srcdir/"
+ install -D iris-flower "$pkgdir/usr/bin/sct"
+} \ No newline at end of file