summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d09bfc17210..0c461710eee2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,32 @@
# Contributor: Florian Hülsmann <fh@cbix.de>
pkgname=jack-matchmaker
-pkgver=0.10.0
-pkgrel=3
+pkgver=0.11.0
+pkgrel=1
pkgdesc='A command line tool to auto-connect JACK ports matching given patterns'
arch=(any)
url='https://github.com/SpotlightKid/jack-matchmaker'
license=(GPL2)
-depends=(jack python)
-makedepends=(python-setuptools)
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+depends=(jack python-cachetools python-pyjacklib)
+makedepends=(python-build python-hatchling python-installer)
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/${pkgname/-/_}-$pkgver.tar.gz")
backup=("etc/conf.d/$pkgname")
-sha256sums=('70b8f53b0c75e8351ccdad4bf37bee8b544643604e0db1938ed749a4c0fa6ba6')
+sha256sums=('a386c8f8d8f9e0dbbf1b75f2260f8534ed9c7e75875571adbc493b0f6538be1d')
build() {
- cd $pkgname-$pkgver
- python setup.py build
+ cd ${pkgname/-/_}-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- cd $pkgname-$pkgver
- python setup.py install --root="$pkgdir" --skip-build --optimize=1
+ cd ${pkgname/-/_}-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ # documentation
+ install -vDm 644 README.md example_patterns.txt \
+ -t "$pkgdir"/usr/share/doc/$pkgname
# systemd service
- install -Dm 644 systemd/jack-matchmaker.conf "$pkgdir"/etc/conf.d/$pkgname
- install -Dm 644 systemd/jack-matchmaker.service -t "$pkgdir"/usr/lib/systemd/user
+ install -vDm 644 systemd/$pkgname.conf \
+ "$pkgdir"/etc/conf.d/$pkgname
+ install -vDm 644 systemd/$pkgname.service \
+ -t "$pkgdir"/usr/lib/systemd/user
}