summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01d6a0766812..8d634c844e18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Nick Econopouly <wry at mm dot st>
pkgname=jami-client-qt-git
-pkgver=r683.3dd206e
+pkgver=r701.0a7aaa5
pkgrel=1
pkgdesc="A free and private communication platform (QT client)"
arch=('x86_64')
-provides=('jami-client-qt')
+provides=('jami-qt')
url="https://git.jami.net/savoirfairelinux/jami-client-qt"
license=('GPL3')
depends=('jami-daemon-git' 'libjamiclient-git' 'qt5-base' 'libnm' 'qrencode' 'libnotify' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-webengine')
makedepends=('git' )
-conflicts=('jami-gnome-git' 'jami-gnome')
+conflicts=('jami-gnome-git' 'jami-gnome' 'jami-qt')
source=("git+$url.git")
sha512sums=(SKIP)
@@ -19,15 +19,13 @@ pkgver() {
}
build() {
- cd jami-client-qt
- mkdir -p build
- cd build
- # /usr is necessary for Arch; see https://archlinux.org/news/binaries-move-to-usrbin-requiring-update-intervention/
- cmake .. -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
- make -j`nproc` # -j`nproc` uses as many cores as possible to speed up the build
+ cmake -B build -S jami-client-qt \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -Wno-dev
+ make -C build -j`nproc` # -j`nproc` uses as many cores as possible to speed up the build
}
package() {
- cd jami-client-qt/build
- make install
+ make -C build DESTDIR="${pkgdir}" install
}