summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6b9aef776d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: cobalt <jpt@mail.ru>
+pkgname=jamin-gtk2
+pkgver=0.98.3
+pkgrel=1
+pkgdesc="A JACK Audio Connection Kit Audio Mastering interface"
+arch=('i686' 'x86_64')
+url="http://jamin.sourceforge.net/"
+license=('GPL')
+depends=('jack' 'libxml2' 'gtk2' 'swh-plugins' 'fftw' 'liblo')
+makedepends=('perl-xml-parser' 'ladspa' 'cvs' 'intltool')
+conflicts=('jamin')
+provides=('jamin')
+options=('!libtool')
+install=${pkgname}.install
+source=('typefix.patch')
+md5sums=('a0a18224447f431503471b3dfe1b715c')
+
+prepare(){
+ LDFLAGS="-ldl"
+ CFLAGS="-Wno-deprecated-declarations -Wno-pointer-sign -Wno-cpp -Wno-unused-but-set-variable -Wno-incompatible-pointer-types -Wno-unused-variable -fcommon"
+ cd "$srcdir"
+ msg ""
+ msg ""
+ msg "Connecting to svs server ..."
+ msg ""
+ msg "Press ENTER when asked for password"
+ cvs -d:pserver:anonymous@jamin.cvs.sourceforge.net:/cvsroot/jamin login
+ cvs -z3 -d:pserver:anonymous@jamin.cvs.sourceforge.net:/cvsroot/jamin co -P jamin
+
+ cd ${srcdir}/jamin
+ patch -p1 -i ../typefix.patch
+}
+
+build() {
+ cd ${srcdir}/jamin
+ ./autogen.sh --prefix=/usr --libdir=/usr/lib
+ make
+}
+
+package() {
+ cd ${srcdir}/jamin
+ make DESTDIR=${pkgdir} install
+}