summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a43c1eacb3c..ade2d2173db5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
pkgname=jape
-pkgver=7_d14
+pkgver=8.1.3
pkgrel=1
pkgdesc='A configurable, graphical proof assistant.'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://japeforall.org.uk/'
license=('GPL')
depends=('java-runtime')
+makedepends=('unzip')
source=('jape'
'jape.desktop')
sha256sums=('43cfa222c48f819c9c4508f4847212d4327f8c7aa49ba4f3bfc9dc4f0f330f8d'
'4677512343900e325f763cf79c8571ae3e493d7f074ebc7c68182ef487e6e579')
-source_i686=("http://www.cs.ox.ac.uk/people/bernard.sufrin/personal/jape.org/BUILDS/$pkgver/Install32bitLinuxjape.jar")
-sha256sums_i686=('ab00be7518d418a8ace5e1ccfe8101d52952a41e42d872e448647657d7c90e98')
source_x86_64=("http://www.cs.ox.ac.uk/people/bernard.sufrin/personal/jape.org/BUILDS/$pkgver/InstallLinuxjape.jar")
-sha256sums_x86_64=('d82a9dc50f4b2d9e0994db21bdc1979b28dd25ff88acb4f459d24c157329dca4')
+noextract=('InstallLinuxjape.jar')
+sha256sums_x86_64=('768ab130d59c75ddab10a2b8dbaf10e0403c57b48a5b837f940af2c7182c72ce')
package() {
cd "$srcdir"
+ unzip InstallLinuxjape.jar || true # Invalid JAR file
+
install -d "$pkgdir/usr/share/jape"
install -m755 jape_engine "$pkgdir/usr/share/jape/"
install -m644 README-UNIX README_encoder.txt "$pkgdir/usr/share/jape/"