summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a18b29885687
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=japi-compliance-checker
+pkgver=2.4
+pkgrel=1
+pkgdesc="A tool for checking backward API/ABI compatibility of a Java library"
+url="https://lvc.github.io/japi-compliance-checker/"
+arch=('any')
+license=('LGPL')
+depends=('perl' 'java-environment')
+
+source=("https://github.com/lvc/japi-compliance-checker/archive/${pkgver}.tar.gz")
+sha256sums=('0fd8ff8539a6f4a2c30379999befc1f9003fbb513f778b018a722360ab8c2229')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install prefix="${pkgdir}/usr/"
+}
+