summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8654efa3562..c4a5e90d03c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,21 @@ pkgname=java8-openjdk-hsdis
_java_ver=8
_jdk_update=242
_jdk_build=08
-_binutils_ver=2.31
+_binutils_ver=2.34
pkgver=${_java_ver}.u${_jdk_update}
_repo_ver=jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
-pkgrel=1
+pkgrel=2
pkgdesc="Disassembler for HotSpot"
arch=('i686' 'x86_64')
url='http://openjdk.java.net/'
license=('GPL2')
_url_src=http://hg.openjdk.java.net/jdk8u/jdk8u
source=(hotspot-${_repo_ver}.tar.gz::${_url_src}/hotspot/archive/${_repo_ver}.tar.gz
- http://ftp.gnu.org/gnu/binutils/binutils-${_binutils_ver}.tar.bz2)
+ http://ftp.gnu.org/gnu/binutils/binutils-${_binutils_ver}.tar.bz2
+ binutils-compat.patch)
sha256sums=('8b799f2ef8e804110aa6ccd23fc46a04047141f7f8ad32936a6fc66f828b24a2'
- '2c49536b1ca6b8900531b9e34f211a81caf9bf85b1a71f82b81ae32fcd8ffe19')
+ '89f010078b6cf69c23c27897d686055ab89b198dddf819efb0a4f2c38a0b36e6'
+ '1ce6f6dccf01aa7172f2a600384244ac7bc91a9cf1bcaa0a9d4e453c775357f5')
prepare() {
cd "${srcdir}/binutils-${_binutils_ver}"
@@ -28,6 +30,12 @@ prepare() {
cd "${srcdir}/hotspot-${_repo_ver}/src/share/tools/hsdis"
mkdir -p build
ln -sf "${srcdir}/binutils-${_binutils_ver}" build/binutils
+
+ # The upstream is currently stuck with binutils 2.31. This patch provides the
+ # compatibility with least recent binutils versions. Remove it once the upstream
+ # updates the binutils version in use.
+ cd "${srcdir}/hotspot-${_repo_ver}"
+ patch -N -p 1 -i "${srcdir}/binutils-compat.patch"
}
build() {