summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 3 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e74db4d305b4..156c9a0dcbec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,3 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
-# for more information on packaging from GIT sources.
-
# Maintainer: Jeffrey E. Bedard <jefbed@gmail.com>
pkgname=jbxvt-git
pkgver=0.5
@@ -14,13 +6,11 @@ pkgdesc="xcb terminal emulator"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/jefbed/jbxvt"
license=('MIT')
-depends=('libxcb' 'xcb-util-keysyms' 'libutempter')
+depends=('xcb-util-keysyms' 'libutempter')
makedepends=('git')
provides=('xterm')
-
_gitroot=https://github.com/jefbed/jbxvt.git
_gitname=jbxvt
-
build() {
cd "$srcdir"
msg "Connecting to GIT server...."
@@ -31,27 +21,19 @@ build() {
else
git clone "$_gitroot" "$_gitname"
fi
-
msg "GIT checkout done or server timeout"
msg "Starting build..."
-
rm -rf "$srcdir/$_gitname-build"
git clone --recursive "$srcdir/$_gitname" "$srcdir/$_gitname-build"
cd "$srcdir/$_gitname-build"
-
- # BUILD HERE
- ./configure
+ # build:
+ ./configure -J
make
}
-
package() {
cd "$srcdir/$_gitname-build"
make DESTDIR="$pkgdir/" install
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
# vim:set ts=2 sw=2 et:
-
-
-