summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e1b5ca36190..19bec0444119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Davide Depau <davide@depau.eu>
-# Co-Maintainer: Felix Golatofski <contact@xdfr.de>
+# Maintainer: Leonardo Costa <leo95.uqhi2 at aleeas dot com>
+# Contributor: Davide Depau <davide@depau.eu>
+# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=jdk11-openj9-bin
_jdkver=11
_jdkminor=0
-_jdkpatch=9
+_jdkpatch=12
_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch}
-_openj9ver=0.23.0
-_buildvershort=11
+_openj9ver=0.27.0
+_buildvershort=7
_buildver=${_buildvershort}_openj9-${_openj9ver}
pkgver=${_jdkfullver}b${_buildver//-/_}
-pkgrel=5
+pkgrel=1
pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk${_jdkver}"
arch=('x86_64')
url="https://adoptopenjdk.net/index.html?variant=openjdk${_jdkver}&jvmVariant=openj9"
@@ -28,9 +29,9 @@ provides=(
)
conflicts=("jdk${_jdkver}-openj9")
options=(!strip)
-source=("https://github.com/AdoptOpenJDK/openjdk${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/OpenJDK${_jdkver}U-jdk_x64_linux_openj9_${_jdkfullver}_${_buildver}.tar.gz")
+source=("https://github.com/AdoptOpenJDK/semeru${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/ibm-semeru-open-jdk_x64_linux_${_jdkfullver}_${_buildver}.tar.gz")
-sha256sums=('812d58fac39465802039291a1bc530b4feaaa61b58664d9c458a075921ae8091')
+sha256sums=('4c2d776f69e3ff7d01cd57c0938b7a7f058264425faf18e3708b905e93f915c4')
_jvmdir=usr/lib/jvm/java-${_jdkver}-j9