summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81ff3d08f522..791256741081 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# $Id$
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
-
pkgname=jdk11-openj9-bin
-_majorver=11.0.1
-_buildver=13
-pkgver=${_majorver}b${_buildver}
+_openj9ver=0.12.1
+_majorver=11.0.2
+_buildver=9_openj9-${_openj9ver}
+pkgver=${_majorver}b${_buildver//-/_}
pkgrel=1
pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk11"
arch=('x86_64')
@@ -12,15 +12,15 @@ url="https://adoptopenjdk.net/index.html?variant=openjdk11&jvmVariant=openj9"
license=('GPL2')
depends=('java-environment-common' 'ca-certificates-utils' 'nss')
provides=(
- "java-environment=11"
+ "java-environment=11"
"java-environment-openjdk=11"
- "java-runtime=11"
+ "java-runtime=11"
"java-runtime-openjdk=11"
"java-runtime-headless=11"
"java-runtime-headless-openjdk=11"
)
-source=("https://github.com/AdoptOpenJDK/openjdk11-binaries/releases/download/jdk-${_majorver}%2B${_buildver}/OpenJDK11U-jdk_x64_linux_openj9_jdk-${_majorver}_${_buildver}_openj9-0.11.0_${_majorver}_${_buildver}.tar.gz")
-sha256sums=('ef9bf07cba79082285a9d426ea4eb3e8df57561ce2afe07cc5f299a8fa203279')
+source=("https://github.com/AdoptOpenJDK/openjdk11-binaries/releases/download/jdk-${_majorver}%2B${_buildver}/OpenJDK11U-jdk_x64_linux_openj9_${_majorver}_${_buildver}_openj9-${_openj9ver}.tar.gz")
+sha256sums=('a9b298391dc0baf49e935683fb13b1b18ef5fd5b1d0e1a1318c8e425ffdbcbcd')
_jvmdir=usr/lib/jvm/java-11-j9