summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 632e86bcbfbe..167faa4571ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgbase=jellyfin-git
pkgname=(jellyfin-git jellyfin-web-git jellyfin-server-git)
-pkgver=10.8.0.alpha5.r1656.g2ce08eb184
+pkgver=10.8.0.alpha5.r2652.gfd1dc860c9
pkgrel=1
pkgdesc='The Free Software Media System'
arch=('i686' 'x86_64' 'armv6h')
url='https://github.com/jellyfin/jellyfin'
license=('GPL2')
-makedepends=('dotnet-sdk' 'npm' 'git')
+makedepends=('dotnet-sdk>=8' 'npm' 'git')
provides=('jellyfin')
conflicts=('jellyfin')
source=('git+https://github.com/jellyfin/jellyfin.git'
@@ -45,8 +45,8 @@ build(){
# Disable dotnet telemetry
export DOTNET_CLI_TELEMETRY_OPTOUT=1
- # Force dotnet to use 7.x when multiple SDKs are installed
- dotnet new globaljson --sdk-version 7.0.0 --roll-forward latestMinor --force
+ # Force dotnet to use 8.x when multiple SDKs are installed
+ dotnet new globaljson --sdk-version 8.0.0 --roll-forward latestMinor --force
dotnet build --configuration Release Jellyfin.Server
# Ideally, this would be run in package() with the --output variable pointing
@@ -66,7 +66,7 @@ package_jellyfin-git() {
package_jellyfin-server-git() {
pkgdesc="Jellyfin server component"
- depends=('dotnet-runtime' 'aspnet-runtime' 'ffmpeg' 'sqlite')
+ depends=('dotnet-runtime>=8' 'aspnet-runtime>=8' 'ffmpeg' 'sqlite')
backup=('etc/conf.d/jellyfin')
provides=('jellyfin-server')
conflicts=('jellyfin-server')