summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7adac1df48f3..572f62b51fb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgbase=jellyfin-git
pkgname=(jellyfin-git jellyfin-web-git jellyfin-server-git)
-pkgver=10.8.0.alpha5.r1140.g11707f8f08
+pkgver=10.8.0.alpha5.r1185.g16fdb127ab
pkgrel=1
pkgdesc='The Free Software Media System'
arch=('i686' 'x86_64' 'armv6h')
url='https://github.com/jellyfin/jellyfin'
license=('GPL2')
-makedepends=('dotnet-sdk-6.0' 'npm' 'git')
+makedepends=('dotnet-sdk' 'npm' 'git')
provides=('jellyfin')
conflicts=('jellyfin')
source=('git+https://github.com/jellyfin/jellyfin.git'
@@ -44,8 +44,8 @@ build(){
# Disable dotnet telemetry
export DOTNET_CLI_TELEMETRY_OPTOUT=1
- # Force dotnet to use 6.x when multiple SDKs are installed
- dotnet new globaljson --sdk-version 6.0.0 --roll-forward latestMinor --force
+ # Force dotnet to use 7.x when multiple SDKs are installed
+ dotnet new globaljson --sdk-version 7.0.0 --roll-forward latestMinor --force
dotnet build --configuration Release Jellyfin.Server
# Ideally, this would be run in package() with the --output variable pointing
@@ -65,7 +65,7 @@ package_jellyfin-git() {
package_jellyfin-server-git() {
pkgdesc="Jellyfin server component"
- depends=('dotnet-runtime-6.0' 'aspnet-runtime-6.0' 'ffmpeg' 'sqlite')
+ depends=('dotnet-runtime' 'aspnet-runtime' 'ffmpeg' 'sqlite')
backup=('etc/conf.d/jellyfin')
provides=('jellyfin-server')
conflicts=('jellyfin-server')