summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1758a5d93d3..abc07250f9f7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
-# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
+# Maintainer: Frederik Schwan <freswa at archlinux dot org>
pkgname=jetbrains-toolbox
-pkgver=1.14.5037
+pkgver=2.3.0.30876
pkgrel=1
pkgdesc='Manage all your JetBrains Projects and Tools'
arch=('x86_64' 'i686')
-url='http://www.jetbrains.com/toolbox/'
-license=('Commercial')
-depends=('java-runtime>=8' 'fuse' 'glib2' 'libxslt' 'libxss')
-options=('!strip')
-source=(https://download.jetbrains.com/toolbox/${pkgname}-${pkgver}.tar.gz
- jetbrains-toolbox.desktop)
-sha512sums=('6e32fd034ea5c194929f308d0b1aab0856319703dae732aa3c84da89c4018e16f034399d5f9e72487f3545c83f41b4d8a889dff7ea3aa8d0b0a6e5278c0eaacb'
- '727b6378a8e3803c552ccae2c0d252eb8e79d213eabeecbd00bc25352cd0ffc6f53abaabf016688136822a65a76b2838f99e909931c21f49382934332446d1b4')
+url='https://www.jetbrains.com/toolbox/'
+license=('custom:jetbrains')
+depends=('fuse' 'glib2' 'libxslt' 'libxss' 'xcb-util-keysyms' 'xdg-utils' 'nss')
+optdepends=('xdg-utils: open URLs')
+options=('!strip' '!debug')
+source=("https://download-cf.jetbrains.com/toolbox/${pkgname}-${pkgver}.tar.gz"
+ jetbrains-toolbox.desktop
+ icon.svg
+ LICENSE)
+b2sums=('a85c8fdb331879f1250d52d9f457a94e4c72f8c955e9cd4fc55b0dc4da48c85e385cc0177f9e805e84ebe838cda4aa20923e59da7c4a50aaa6cbbf7d1b2db53d'
+ '29b6d4be91d9276bce9e5413fb877db82de414198e343ff3f7aa5d03f65cf42c80f78ec3b43f601394fecc6a31712d1c475f3fdec71e51be5732ec7b1eb8dca9'
+ '4b10487746fcb7f328cbdc8b17432f82618c5695baee4ef30e23ff3c4d4b6096daf2fcdfb4c1e2e179e2e61f68bbd88104e5df5a2e6e969aad0a68a75cfff496'
+ 'dadaf0e67b598aa7a7a4bf8644943a7ee8ebf4412abb17cd307f5989e36caf9d0db529a0e717a9df5d9537b10c4b13e814b955ada6f0d445913c812b63804e77')
package() {
- install -d -m 755 "${pkgdir}/usr/bin/"
+ install -dm755 "${pkgdir}"/usr/bin/
+ install -Dm644 "${srcdir}"/${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
+ install -Dm644 "${srcdir}"/icon.svg "${pkgdir}"/usr/share/pixmaps/${pkgname}.svg
+ install -Dm755 "${srcdir}"/${pkgname}-${pkgver}/${pkgname} "${pkgdir}"/opt/${pkgname}/${pkgname}
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.txt
- install -D -m 644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -D -m 755 "${srcdir}/${pkgname}-${pkgver}/${pkgname}" "${pkgdir}/opt/${pkgname}/${pkgname}"
-
- ln -s "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ ln -s /opt/${pkgname}/${pkgname} "${pkgdir}"/usr/bin/${pkgname}
}