summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4ab000fd429..a1417aabad92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
pkgname=jngl
-pkgver=0.9.2
-pkgrel=3
+pkgver=1.3.1
+pkgrel=1
pkgdesc="One of the easiest 2D game libraries for C++ and Python"
arch=('i686' 'x86_64')
-url="http://jngl.watteimdocht.de/"
-license=('GPL3')
-depends=('boost' 'freetype2' 'fontconfig' 'glib2' 'libjpeg6' 'libpng12' 'libvorbis' 'libxext' 'libxxf86vm' 'mesa' 'openal' 'python2')
-makedepends=('scons' 'git')
-source=('python27.patch')
-md5sums=('58ec66f99186c5e491a4657559f203d1')
-sha1sums=('61c55403238c7c7d95de87bb720230f47fd75a62')
+url="https://bixense.com/jngl/"
+license=('ZLIB')
+depends=('sdl2' 'fontconfig' 'glew' 'libwebp' 'openal' 'libvorbis' 'boost')
+
+makedepends=('meson' 'ninja')
+source=("https://github.com/jhasse/jngl/archive/v$pkgver.tar.gz")
+md5sums=('9dcbcde797ae92b61c7fd0fdaf044e47')
build() {
- git clone https://github.com/jhasse/JNGL.git
- patch $srcdir/JNGL/SConstruct < python27.patch
- cd $srcdir/JNGL
- scons python=1|| return 1
- ./install.sh $pkgdir/usr || return 1
- install -D -m644 "$srcdir/JNGL/python/libjngl.so" "${pkgdir}/usr/lib/python2.7/site-packages/jngl.so" || return 1
+ cd $srcdir/jngl-$pkgver
+ mkdir build
+ cd build
+ meson .. --prefix=${pkgdir}/usr
+}
+package() {
+ cd $srcdir/jngl-$pkgver/build
+ ninja install
}