summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a590575e615..7d6cfec20ea7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=jottalib
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A library to access files stored at jottacloud.com"
arch=("any")
url="https://github.com/havardgulldahl/jottalib"
@@ -16,13 +16,17 @@ depends=('python2-requests'
'python2-lxml'
'python2-xattr'
'python2-chardet')
-source=("$pkgname.tar.gz::https://github.com/havardgulldahl/jottalib/archive/v0.5.1.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/havardgulldahl/jottalib/archive/v0.5.1.tar.gz")
sha256sums=('607e5270c15e593e0df494493d371d996053d45cfc2fe44a09020719fe5feaa3')
+build(){
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+}
package() {
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}