summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 916b683d2f69..d377ccb2e974 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=jqp-bin
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A TUI playground to experiment with jq"
arch=('x86_64')
url="https://github.com/noahgorstein/jqp"
@@ -10,10 +10,12 @@ license=('MIT')
conflicts=('jqp')
depends=('tar')
options=(!strip) # necessary otherwise the AppImage file in the package is truncated
-source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/jqp_${pkgver}_Linux_${arch[0]}.tar.gz")
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/jqp_${pkgver}_Linux_${arch[0]}.tar.gz")
sha256sums=(7456b61ce3bde270f955df71cdbb9281b9002a0a2cb57372b85c9ff105520593)
+_bin='jqp'
+
package() {
- install -Dm 755 "${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm 755 "${_bin}" -t "${pkgdir}/usr/bin"
install -Dm 644 "README.md" -t "${pkgdir}/usr/share/doc/${pkgname}"
}