summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be18e9b28f30..f03f791b7e7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,19 +8,31 @@ arch=('any')
url="https://maebert.github.io/jrnl"
license=('MIT')
depends=('python-pyxdg>=0.26'
- 'python-parsedatetime>=2.4'
+ 'python-pyxdg<1.0'
+ 'python-parsedatetime>=2.4'
+ 'python-parsedatetime<3.0'
'python-cryptography>=2.7'
+ 'python-cryptography<3.0'
'python-passlib>=1.7'
+ 'python-passlib<2.0'
'python-parsedatetime>=2.4'
+ 'python-parsedatetime<3.0'
'python-keyring>=19.0'
+ 'python-keyring<20.0'
'python-pytz>=2019.1'
- 'python-tzlocal>1.5'
+ 'python-pytz<2020.0'
+ 'python-tzlocal>1.5'
'python-tzlocal<3.0'
'python-asteval>=0.9.14'
+ 'python-asteval<1.0'
'python-colorama>=0.4.1'
+ 'python-colorama<1.0'
'python-dateutil>=2.8'
+ 'python-dateutil<3.0'
'python-yaml>=5.1'
- 'python-ansiwrap>=0.8.4')
+ 'python-yaml<6.0'
+ 'python-ansiwrap>=0.8.4'
+ 'python-ansiwrap<1.0')
source=("https://pypi.python.org/packages/source/j/$pkgname/$pkgname-${pkgver}.tar.gz")
sha256sums=('c780f656e61516fe7cbb1fa5e96e1959df3f7340c6c6cc7af69239cc19dd3dc1')