summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8effe61cd6d0..c4b84047d1e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
-# Maintainer: Tobias Frilling <tobias@frilling-online.de>
+# Maintainer: Manuel Palenzuela <sadshinobi@protonmail.com>
+
pkgname=jrnl-git
pkgver=1.9.7.r16.g15ef974
pkgrel=1
pkgdesc="A simple command line journal application that stores your journal in a plain text file"
arch=('any')
-url="http://maebert.github.io/jrnl/"
+url="https://jrnl.sh/"
license=('MIT')
-depends=('python' 'python-dateutil' 'python-keyring' 'python-parsedatetime' \
- 'python-pytz' 'python-tzlocal')
+depends=('python-asteval' 'python-dateutil' 'python-keyring' 'python-parsedatetime' \
+ 'python-pytz' 'python-tzlocal' 'python-pyaml' 'python-six' 'python-passlib' 'python-pyxdg' 'python-cryptography')
makedepends=('git')
conflicts=("${pkgname%-git}")
options=(!emptydirs)
@@ -16,7 +17,8 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ printf '0.r%s.%s' \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {