summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bebbfb08709b..166daf9e7216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=jrnl-git
_gitname=jrnl
pkgver=v2.8.1.r12.g5e87ff1
-pkgrel=5
+pkgrel=2
pkgdesc="Collect your thoughts and notes without leaving the command line"
arch=('any')
url="https://jrnl.sh/"
license=('GPL3')
depends=('python' 'python-ansiwrap' 'python-asteval' 'python-colorama' 'python-cryptography' 'python-keyring' 'python-parsedatetime' 'python-dateutil' 'python-pyxdg' 'python-pyaml')
-checkdepends=('python-behave' 'python-pytest' 'python-black' 'python-poetry')
-makedepends=('git' 'make')
+checkdepends=('python-behave' 'python-pytest' 'python-black')
+makedepends=('git' 'python-dephell' 'python-setuptools')
conflicts=("jrnl")
source=("git+https://github.com/jrnl-org/jrnl.git")
md5sums=('SKIP')
@@ -22,16 +22,25 @@ pkgver() {
check() {
cd "$_gitname"
+ pytest .
+ behave --no-skipped --format progress
+
black setup.py --diff | patch
- make test
+ black --check --diff .
+}
+
+prepare() {
+ cd "$_gitname"
+ dephell deps convert --from pyproject.toml --to setup.py --envs main
}
build() {
cd "$_gitname"
- make install
-}
+ python setup.py build
+}
-package(){
- true
+package() {
+ cd "$_gitname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}