summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD84
1 files changed, 43 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2b143f733ea..8e065bbafa01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,29 @@
_pkgbase=julia
pkgbase=${_pkgbase}-git
-pkgname=('julia-git' 'julia-git-docs')
-pkgver=1.3.0.DEV.r44719.gefd794e199
+pkgname=(julia-git julia-git-docs)
+pkgver=1.5.0.DEV.r45903.gedc1b7d14a
pkgrel=1
+arch=(x86_64)
pkgdesc='High-level, high-performance, dynamic programming language'
-arch=('x86_64')
-url="https://julialang.org"
-license=('MIT')
-makedepends=('cmake' 'gcc-fortran' 'gmp' 'python2' 'git')
-makedepends+=('cblas' 'hicolor-icon-theme' 'libgit2' 'libunwind' 'libutf8proc'
- 'mbedtls' 'mpfr' 'openblas' 'openlibm' 'pcre2' 'suitesparse'
- 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache') # 'llvm' 'patchelf' 'intel-mkl'
+url='https://julialang.org/'
+license=(MIT)
+depends=(cblas hicolor-icon-theme libgit2 libunwind libutf8proc openblas
+ suitesparse mbedtls mpfr openlibm pcre2
+ xdg-utils desktop-file-utils gtk-update-icon-cache) # 'llvm' 'patchelf' 'intel-mkl'
+makedepends=(cmake gcc-fortran gmp python git)
# Needed if building the documentation
#makedepends+=('juliadoc-git' 'texlive-langcjk' 'texlive-latexextra')
source=(git://github.com/JuliaLang/julia.git#branch=master
Make.user
- julia-makefile.patch
- cblas.patch)
+ julia-system-cblas.patch
+ libunwind-version.patch
+ make-install-no-build.patch)
sha256sums=('SKIP'
- '21f97b3441097e71db59e2205f644466d829bbd0b73a34bc8b857b4390cf8ffc'
- '030b37d711a08567e7f9c5f0626dec7aed02c83373b5ec666d519897b50218ea'
- '5eb9280c6b91c9be15a52de7dc5f05e69a5edbfe1c5d1f62497470a1aa0d1fa8')
+ '1aee33d62dcd8e6b65672bd9996a61c83e44056dd31efa79761cb85effb0e6a1'
+ 'd4c8fe9eec1bc416549924ae328ceb3f63cc736ecd5e67886faa924e7c14bc5d'
+ '856dab2da8124df95e4fbd17f1164bebe1b10e99852fedf38f9dfe31f8ae295c'
+ '0b57e0bc6e25c92fde8a6474394f7a99bfb57f9b5d0f7b53f988622ae67de8b7')
pkgver() {
@@ -44,18 +46,22 @@ prepare() {
msg2 'Configuring the build...'
cp -v $srcdir/Make.user .
- msg2 'Patching make install...'
- patch -p0 -i ../julia-makefile.patch
+ # Add and use option to build with system cblas
+ patch -p1 -i ../julia-system-cblas.patch
- # add and use option to build with system cblas
- # https://github.com/JuliaLang/julia/pull/29540
- patch -p1 --no-backup-if-mismatch -i ../cblas.patch
+ # Fixing libunwind version check
+ # https://github.com/JuliaLang/julia/pull/29082
+ patch -p1 -i ../libunwind-version.patch
+
+ # Don't build again in install
+ patch -p1 -i ../make-install-no-build.patch
}
build() {
# See FS#57387 for why USE_SYSTEM_LLVM=0 is used, for now
# See FS#58221 for why USE_SYSTEM_ARPACK=0 is used, for now
- env CFLAGS="$CFLAGS -w" CXXFLAGS="$CXXFLAGS -w" make -C "$_pkgbase"
+ export PATH="$srcdir/bin:$PATH"
+ env CFLAGS="$CFLAGS -w" CXXFLAGS="$CXXFLAGS -w" make VERBOSE=1 -C "$_pkgbase"
# Building doc
cd $_pkgbase/doc
@@ -69,31 +75,31 @@ check() {
# this is the make testall target, plus the --skip option from
# travis/appveyor/circleci (one test fails with DNS resolution errors)
- ../julia --check-bounds=yes --startup-file=no ./runtests.jl all --skip Sockets
+ ../julia --check-bounds=yes --startup-file=no ./runtests.jl all --skip Sockets --skip Distributed --skip LibGit2/libgit2
find ../stdlib \( -name \*.cov -o -name \*.mem \) -delete
rm -r depot/compiled
}
package_julia-git() {
- depends=('cblas' 'hicolor-icon-theme' 'libgit2' 'libunwind' 'libutf8proc'
- 'mbedtls' 'mpfr' 'openblas' 'openlibm' 'pcre2' 'suitesparse'
- 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache') # 'llvm' 'patchelf' 'intel-mkl'
optdepends=('openblas-lapack: multithreaded replacement for lapack'
'fftw: If using the FFTW package from julia'
'gnuplot: If using the Gaston Package from julia')
provides=('julia')
conflicts=('julia')
- backup=('etc/julia/juliarc.jl')
+ backup=(etc/julia/startup.jl)
- CFLAGS=${CFLAGS//-march=i686/-march=pentium4}
- CXXFLAGS=${CXXFLAGS//-march=i686/-march=pentium4}
- make -C "$_pkgbase" DESTDIR="$pkgdir" install
+ make -C "$_pkgbase" DESTDIR="$pkgdir" install \
+ prefix=/usr \
+ libexecdir=/usr/lib \
+ sysconfdir=/etc
- # Documentation and examples are in the julia-docs package
- rm -rf "$pkgdir/usr/share/"{doc,julia/doc,julia/examples}
+ # Documentation is in the julia-docs package.
+ # Man pages in /usr/share/julia/doc/man are duplicate.
+ rm -rf "$pkgdir/usr/share/"{doc,julia/doc}
- install -Dm644 "$_pkgbase/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgbase/LICENSE.md"
+ install -Dm644 "$_pkgbase/LICENSE.md" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
# Remove files that don't belong into the package
find ${pkgdir} -name ".gitignore" -delete
@@ -102,17 +108,15 @@ package_julia-git() {
package_julia-git-docs() {
arch=('any')
pkgdesc='Documentation and examples for Julia'
- depends=('julia')
- provides=('julia-docs')
- conflicts=('julia-docs' 'julia-git-doc')
+ depends=(julia)
+ provides=(julia-docs)
+ conflicts=(julia-docs julia-git-doc)
install -d "$pkgdir/usr/share/doc"
cp -r "$_pkgbase/doc" "$pkgdir/usr/share/doc/$_pkgbase"
- cp -r "$_pkgbase/examples" "$pkgdir/usr/share/doc/$_pkgbase/examples"
- install -Dm644 "$_pkgbase/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgbase/LICENSE.md"
-
- # Remove double
- rm -rf "$pkgdir/usr/share/doc/julia/man/"
+ rm -rf "$pkgdir/usr/share/doc/julia/man"
+ install -Dm644 "$_pkgbase/LICENSE.md" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
# Installing built docs. Adjust it accordingly to your changes in build()
cd "$_pkgbase/doc/_build"
@@ -124,5 +128,3 @@ package_julia-git-docs() {
# Remove files that don't belong into the package
find ${pkgdir} -name ".gitignore" -delete
}
-
-# vim:set ts=2 sw=2 et: