summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe58ffb4d508
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro dot_org>
+
+pkgname=julia-orderedcollections
+_pkgname=OrderedCollections
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Julia implementation of associative containers that preserve insertion order '
+arch=(any)
+url="https://github.com/JuliaCollections/OrderedCollections.jl"
+license=(MIT)
+depends=(julia)
+
+source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
+sha256sums=('33d4e568f7cbffe9187d7548e86487f375ec0be07fa0da3743a2e008a8453707')
+
+package() {
+ cd $_pkgname.jl-$pkgver
+ install -dm755 $pkgdir/usr/share/julia/environments/v1.0/$_pkgname
+ cp -r {src,test} $pkgdir/usr/share/julia/environments/v1.0/$_pkgname/
+}
+
+check() {
+ cd $_pkgname.jl-$pkgver
+ JULIA_LOAD_PATH=src:$JULIA_LOAD_PATH julia test/runtests.jl
+}