summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 7 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 532c4929d4f9..a1537198d5d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,24 @@
pkgname=julia-zmq
_pkgname=ZMQ
-pkgver=1.0.0
-pkgrel=6
+pkgver=1.2.0
+pkgrel=1
pkgdesc='Julia binding to the native API of ØMQ project'
arch=(any)
url=https://github.com/JuliaInterop/ZMQ.jl
license=(MIT)
-depends=(julia julia-compat julia-loadpath zeromq)
+depends=(julia julia-compat julia-loadpath julia-zeromq-jll zeromq)
makedepends=(julia-distrohelper)
-_commit=ffed2d514d4e73cf0f8c700d5d33cd5f9dec9ee0
+_commit=46d153bfe7dea6702cdf32d025d8b5ff81a4e59f
source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
$pkgname-$pkgver-Deps.toml::https://raw.githubusercontent.com/JuliaRegistries/General/$_commit/${_pkgname:0:1}/$_pkgname/Deps.toml
$pkgname-$pkgver-Package.toml::https://raw.githubusercontent.com/JuliaRegistries/General/$_commit/${_pkgname:0:1}/$_pkgname/Package.toml
$pkgname-$pkgver-Versions.toml::https://raw.githubusercontent.com/JuliaRegistries/General/$_commit/${_pkgname:0:1}/$_pkgname/Versions.toml)
-sha256sums=('f8c3cc104b3e8dc7ae09da9787427fb2ca45f3e4b46c98a6c8eace78216b1333'
- 'd27c36dfdb33f4cfb29f85c57509fa0874bd0f92e8c3d88ef87fcc93f3e32bcc'
+sha256sums=('78eee3d1e1d2326523ebb053300da884a16abbcdb22d8271b43c3531f8d982d3'
+ 'e5f79dae79a511964865c1508fa9d8d453fe5040a1789101b00c1c85ee0e6fcb'
'6b51aedfcda4ecddeed07880756db0791b33bb158237fdb714ff695f1902f417'
- 'f2fc26069146b5cfebee4e243023d3793f843eccba6e48c02fa92d5124599da2')
+ '3711ed32395591bacbde08b7e4bbc71efb3abe669f5de59427bba5a632b19af5')
_slug() {
dh_julia slug "$srcdir"/"$pkgname"-$pkgver-{Package,Versions}.toml
@@ -32,25 +32,6 @@ _project() {
prepare() {
# Generate a Project.toml from Registry metadata
rm -f Project.toml && _project
-
- cat >$_pkgname.jl-$pkgver/deps/deps.jl << 'EOF'
-if isdefined((@static VERSION < v"0.7.0-DEV.484" ? current_module() : @__MODULE__), :Compat)
- import Compat.Libdl
-elseif VERSION >= v"0.7.0-DEV.3382"
- import Libdl
-end
-const libzmq = "/usr/lib/libzmq.so"
-function check_deps()
- global libzmq
- if !isfile(libzmq)
- error("$(libzmq) does not exist, please report an issue with this PKGBUILD")
- end
-
- if Libdl.dlopen_e(libzmq) in (C_NULL, nothing)
- error("$(libzmq) cannot be opened, please report an issue with this PKGBUILD")
- end
-end
-EOF
}
package() {