summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f85c487eb97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=jupyter_dashboards
+pkgver=0.7.0
+pkgrel=1
+pkgdesc='Extension for deploying jupyter notebooks as dynamic dashboards'
+url="https://pypi.python.org/pypi/$pkgname/"
+depends=('git' 'jupyter-notebook')
+license=('BSD')
+arch=('any')
+source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('69a8dcb85acda20862bd2c52b97f9c5b5f0fbc23c73c2824460269d0622b0b20')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}