summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e70689f0bd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+_name=jupyterlab-git
+pkgname=jupyterlab-extension-jupyterlab_git
+pkgver=0.30.0b1
+pkgrel=1
+pkgdesc='Git extension for JupyterLab'
+arch=(any)
+url=https://github.com/jupyterlab/$_name
+license=(BSD)
+depends=(jupyterlab jupyter-server python-nbdime python-packaging python-pexpect)
+provides=(jupyterlab-extension-git python-jupyterlab-git)
+_wheel="${_name/-/_}-$pkgver-py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
+sha256sums=('d5c2daced422004643a4eab8e3a5676e204e9df32cae54674684965e2e20870f')
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ install -d "$site"
+ unzip "$_wheel" -d "$site"
+ mv "$site/${_name/-/_}-$pkgver.data/data/"* "$pkgdir/usr/"
+}