summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e93edb28a6e7..cbc236ac92bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=just-git
-pkgver=0.2.15.173
+pkgver=0.3.1.326
pkgrel=1
pkgdesc="Just a command runner, like make."
arch=('x86_64' 'i686')
url="https://github.com/casey/just"
license=('WTFPL' 'MIT' 'Apache-2.0')
-depends=()
makedepends=('cargo')
-optdepends=()
provides=('just')
conflicts=('just')
-source=($pkgname::git+https://github.com/casey/just.git)
+source=(git+https://github.com/casey/just.git)
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
+ cd $pkgname
+ echo $(git describe|tr -d v).$(git rev-list --count HEAD)
}
build() {
- cd $pkgname
- cargo build --release
+ cd $pkgname
+ cargo build --release
}
package() {
- cd $pkgname
- install -D -m755 "$srcdir/$pkgname/target/release/just" "$pkgdir/usr/bin/just"
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/just" "$pkgdir/usr/bin/just"
}