summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61628233afa2..ff7b39d7f7a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
set -u
pkgname='justniffer'
-pkgver='0.5.12'
+pkgver='0.5.15'
pkgrel='1'
pkgdesc='TCP sniffer. It reassembles and reorders packets and displays the tcp flow in a customizable way.'
arch=('i686' 'x86_64')
@@ -14,9 +14,9 @@ url='http://justniffer.sourceforge.net'
license=('GPL')
depends=('python2>=2.4' 'libpcap' 'boost') # 'libnids' the package includes its own custom version of libnids
# I suspect python2 is a makedepends. No python code goes into the package.
-_verwatch=('http://sourceforge.net/projects/justniffer/files/justniffer/' "\s\+${pkgname} \([^<]\+\).*" 'f')
-source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}%200.5.12/${pkgname}_0.5.12.tar.gz")
-sha256sums=('e5bb7a1c3cfc72314b8686cbb121d2c4fbf2dd0484a7e564e67d6bb880ee3329')
+_verwatch=('https://sourceforge.net/projects/justniffer/files/' "\s\+${pkgname}_\([0-9.]\+\)\.tar\.gz" 'f')
+source=("https://sourceforge.net/projects/${pkgname}/files/${pkgname}_${pkgver}.tar.gz")
+sha256sums=('d1ad84933cceda842e6b9b2f34891daa69279b643bd346f9e4778910eba50bf6')
prepare() {
set -u
@@ -28,11 +28,19 @@ prepare() {
sed -i -e 's/python/python2/' 'python/justniffer-grab-http-traffic.in'
sed -i -e 's/do_subst = python/do_subst = python2/' python/Makefile.*
- # The behaviour of inline is no longer compatible with the included libnids so we take them out
+ # The behaviour of inline is no longer compatible with the included libnids so we take them out (0.5.12)
sed -i -e 's/^inline int/int/g' 'lib/libnids-1.21_patched/src/'{util.c,util.h}
# This fixes the i686 version
sed -i -e 's/^inline / /g' 'lib/libnids-1.21_patched/src/checksum.c'
+ #Unpatch the non working inline patch for GCC5 (0.5.14, 0.5.15)
+ sed -i -e 's:__GNUC__>=5:0:g' 'lib/libnids-1.21_patched/src/util.h'
+ sed -i -e 's:__GNUC__<5:1:g' 'lib/libnids-1.21_patched/src/util.c'
+
+ sed -i -e '/^ACLOCAL_AMFLAGS =/d' 'Makefile.am'
+
+ rm -rf 'm4/' # http://stackoverflow.com/questions/3096989/libtool-version-mismatch-error
+ mkdir 'm4'
autoreconf --force --install
CPPFLAGS='-P' CXXFLAGS='-O2' CFLAGS='-O2' LDFLAGS='-Wl,-z,defs' \
./configure --enable-dependency-tracking --enable-python --prefix='/usr' --sbindir='/usr/bin' PYTHON='python2'
@@ -42,7 +50,8 @@ prepare() {
build() {
set -u
cd "${pkgname}-${pkgver}"
- make -s -j "$(nproc)"
+ #local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
+ make -s # -j "${_nproc}" # Too small
set +u
}