summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08942537e490..284a069ca0b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=k3s-git
pkgver=r1.7d1baa9
-pkgrel=2
+pkgrel=3
pkgdesc='Lightweight Kubernetes'
arch=(x86_64)
url='https://github.com/rancher/k3s'
@@ -23,7 +23,9 @@ build() {
}
package() {
- DESTDIR="$pkgdir" make -C $pkgname install
+ install -Dm755 k3s "$pkgdir/usr/bin/k3s"
+ install -Dm755 kubectl "$pkgdir/usr/bin/kubectl"
+ install -Dm755 hyperkube "$pkgdir/usr/bin/hyperkube"
install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}